collabora-online/debian/rules

22 lines
569 B
Makefile

#!/usr/bin/make -f
# see EXAMPLES in dpkg-buildflags(1) and read /usr/share/dpkg/*
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/default.mk
CONFFLAGS = --enable-silent-rules --prefix=/usr --localstatedir=/var --sysconfdir=/etc --with-lokit-path=`pwd`/bundled/include --disable-setcap --disable-tests $(CONFIG_OPTIONS)
# main packaging script based on dh7 syntax
%:
dh $@ --with=systemd --parallel
override_dh_auto_configure:
./configure $(CONFFLAGS)
override_dh_auto_test:
# do not test
override_dh_installinit:
# no init.d scripts here, assume systemd